speed dials moves up on it own...possesed!?

  • J. Jeff Johnson
  • J. Jeff Johnson's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
13 years 1 week ago #4099 by J. Jeff Johnson
J. Jeff Johnson created the topic: speed dials moves up on it own...possesed!?
New to the site, Hi !

I've read all of the posts on the Mark VII with great relish since info is scarce on this machine. My speed control works except as described below.

The only other problem is reverse don't work. Have yet to take it apart and clean as others have advised.

My speed control, when on low 750 rpm, mysteriously moves by it self to about 1100 rpm then stops. (Twilight Zone Theme playing in the back ground :shock: )

My question is how do you access this mechanisms to service or replace.
I hate to just start unscrewing and popping cover without knowing where the heck to start. Any help at all is appreciated, thanks in advance

Please Log in to join the conversation.

  • admin
  • admin's Avatar
  • Visitor
  • Visitor
13 years 1 week ago #4100 by admin
admin replied the topic: Re: speed dials moves up on it own...possesed!?
Some of the others might have more info but i have witnessed this same type of behavior. My problem turned out that the plastic pork chop had a flat spot on it due to some melting that occurred to to a bad bearing. This would cause my speed to migrate with out turning the dial. You can pop the side cover off and look directly at the pork chop to see if there is any damage there.

Please Log in to join the conversation.

  • J. Jeff Johnson
  • J. Jeff Johnson's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
13 years 3 days ago #4152 by J. Jeff Johnson
J. Jeff Johnson replied the topic: Re: speed dials moves up on it own...possesed!?
Thanks for the reply, I'll check it out!

Please Log in to join the conversation.

Time to create page: 0.208 seconds

Administrator

Free Joomla! template by L.THEME